导入字体

Kanzi 中的默认字体是 Fira Sans Regular。存储在 <KanziInstallation>/Studio/Asset Library/Fonts 中。您想使用自己的字体时,可以将其导入至您的 Kanzi Studio 工程。

您可以在 Kanzi 应用程序中使用以下字体类型:

确保使用的字体包含 Kanzi 应用程序中想要呈现的文本需要的所有字形。

导入字体

要将字体导入到您的工程中:

  1. 选择文件 (File) > 导入 (Import) > 导入字体 (Import Fonts)。
    导入字体 (Import Fonts) 窗口即会打开。
  2. 在字体 (Fonts) 列中选择要导入的字体,然后在字型 (Typefaces) 列中双击要导入的字型。
    当打开导入字体 (Import Fonts) 窗口时,Kanzi Studio 会显示系统字体。要从其他位置导入字体,请点击浏览 (Browse) 并选择要从中导入字体的目录。
  3. 选择完要导入的字体的字型之后,请点击导入 (Import)。
    您可以在素材库 (Library) > 资源文件 (Resource Files) > 字体 (Fonts) 中看到所有已导入的字体。

使用 iType 链接字体

使用 iType 链接字体链接多个 TrueType 字体,并通过引用一个字体文件使用所有链接字体中的字形。例如,您可以链接某一字体和拉丁字形,以及某一字体和中文字形以在您的 Kanzi 应用程序中渲染两种语言中使用的字形。

请访问 support.rightware.com 并使用 Kanzi 支持门户 提交申请,获取 Kanzi 方面有关 iType 链接字体的支持。

要求

要创建 iType 链接字体文件,您需要 Monotype iType FontLinking Kit for iType 5.3.3。

安装对 iType 链接字体的支持文件

要安装对 iType 链接字体的支持文件:

  1. 备份 <KanziInstallation>/Studio/Bin 目录。
  2. 解压包含提供 iType 链接字体支持文件的 Kanzi Studio 预览 (Preview) 和 Kanzi Engine 二进制文件的 zip 文件包:
  3. 在 <KanziInstallation>/Studio/Bin 目录中,用在上一步中解压的文件替换 Kanzi Studio 预览 (Preview) 和 Kanzi Engine 二进制文件。

使用 iType 链接字体

要使用 iType 链接字体,请执行以下操作:

  1. 在 Windows 资源管理器中添加要链接到 <KanziWorkspace>/Projects/<ProjectName>/Application/bin 目录的 ttf 字体。
  2. 要创建 ltt 链接字体文件,在 iType FontLinking Kit 中打开 FontLinker 工具:
    1. 在“编辑”菜单中选择“修改”。
      “字体链接”窗口即会打开。
    2. 在“字体链接”窗口中点击“添加字体”,并选择您在第一步中已添加到 Application/bin 目录的 ttf 字体文件。
    3. 在“字体链接”窗口中点击每一个在上一步中导入的 tff 字体文件的复选框,并点击“应用”。添加完所有要链接的字体后,点击“确定”。
    4. 在“文件”菜单中选择“保存”,将链接字体另存为 ltt 文件。
  3. 在 Kanzi Studio 中导入您在上一步中保存的 ltt 字体。请参阅 导入字体。
    在 Kanzi Studio 中,您可以在 素材库 (Library) > 资源文件 (Resource Files) > 字体 (Fonts) 中看到链接的字体文件。
    链接字体文件在 Fonts 目录中引用在位于 <KanziWorkspace>/Projects/<ProjectName>/Application/bin 目录中的 ttf 字体文件。
  4. 在 Kanzi Studio 的 工程 (Project) 中选择一个想要使用链接字体的 文本块 (Text Block) 节点,并在 属性 (Properties) 中将 字体 (Font) 属性设置为该字体。
    在该 文本块 (Text Block) 节点中,您现在可以使用 ltt 链接字体文件中链接的所有 ttf 文件的字形。

另请参阅

使用文本块 (Text Block) 节点

本地化