プロジェクトのバックアップを作成する

Kanzi Studio で作成できるもの:

  • 自動バックアップ。Kanzi Studio はプロジェクトを自動保存するたびに、プロジェクトのコピーを作成し、拡張子 .autosave のファイルに格納します。Kanzi Studio は .autosave ファイルのコピーを 1 つだけ保持します。自動バックアップの設定 および 自動バックアップからプロジェクトを復元する を参照してください。

  • 手動バックアップ。プロジェクトを保存するたびに、Kanzi Studio はプロジェクトのコピーを作成し、拡張子 _N のファイルに格納します。N はバックアップの連番です。Kanzi Studio は最新 10 個のプロジェクトファイルのバックアップを保持します。例えば、プロジェクト名が Orchard の場合、プロジェクトファイルは Orchard.proj.kzm、最新のバックアップは Orchard.proj.kzm_1、その 1 つ前のバックアップは Orchard.proj.kzm_2 のようになります。手動バックアップからプロジェクトを復元する を参照してください。

  • Restore Points。プロジェクトを以前のバージョンに戻すには、リストアポイントを使用します。プロジェクトのリストアポイントを作成すると、Kanzi Studio はプロジェクトの完全なコピーを <ProjectName>/Restore Points ディレクトリ内のタイムスタンプ付きディレクトリに作成します。リストアポイントの作成 と リストアポイントからプロジェクトを復元する を参照してください。

自動バックアップの設定

Kanzi Studio はプロジェクトを自動保存するたびに、プロジェクトのコピーを作成し、拡張子 .autosave のファイルに格納します。Kanzi Studio は .autosave ファイルのコピーを 1 つだけ保持します。

デフォルトで、Kanzi Studio は15分ごとにプロジェクトを自動的に保存します。Kanzi Studio は、プロジェクトに変更を加えた場合にのみ自動的にプロジェクトを保存します。

自動バックアップを設定するには、Edit > User Preferences を選択し、Autosave で:

  • 自動バックアップを使用するには、Enabled 設定を有効にしてください。

  • 自動バックアップの間隔を設定するには、Interval テキストボックスに分数を入力してください。

    ../../_images/user-preferences-autosave-interval.png

自動バックアップからプロジェクトを復元する

プロジェクトを自動バックアップから復元するには、File > Open Backup Save を選択し、Autosave を選択して自動バックアップを開きます。

../../_images/open-autosave-backup.png

手動バックアップからプロジェクトを復元する

プロジェクトを保存するたびに、Kanzi Studio はプロジェクトのコピーを作成し、拡張子 _N のファイルに格納します。N はバックアップの連番です。Kanzi Studio は最新 10 個のプロジェクトファイルのバックアップを保持します。例えば、プロジェクト名が Orchard の場合、プロジェクトファイルは Orchard.proj.kzm、最新のバックアップは Orchard.proj.kzm_1、その 1 つ前のバックアップは Orchard.proj.kzm_2 のようになります。

プロジェクトを手動バックアップから復元するには、File > Open Backup Save を選択し、Backup と開きたいバージョンを選択します。

../../_images/open-manual-save-backup.png

リストアポイントの作成

リストアポイントを使用して、プロジェクトの以前のバージョンに戻ります。プロジェクトのリストアポイントを作成すると、Kanzi Studio はプロジェクトの完全なコピーを <ProjectName>/Restore Points ディレクトリ内のタイムスタンプ付きディレクトリに作成します。

プロジェクトのリストアポイントを作成することは、例えばプロジェクトに大きな変更を加える前の状態に戻ることができるため、有用です。

リストアポイントを作成するには、Kanzi Studio でプロジェクトを開いている状態で、重要な変更を加える前に、File > Save Restore Point を選択します。

Kanzi Studio は、プロジェクトの完全なコピーを <ProjectName>/Tool_project/Restore Points ディレクトリ内のタイムスタンプ付きディレクトリに作成します。

../../_images/save-restore-point.png

リストアポイントからプロジェクトを復元する

リストアポイントからプロジェクトを復元するには:

  1. 復元したいプロジェクトのプロジェクトディレクトリに移動し、Tool_project/Restore Points ディレクトリを開きます。

  2. 復元したいプロジェクトがあるタイムスタンプ付きディレクトリを開き、Kanzi Studio プロジェクトファイルを開きます。選択した復元ポイントからのプロジェクトが、Kanzi Studio の新しいインスタンスで開きます。

関連項目

プロジェクトの中を整理すること

Kanzi Studio プロジェクトの設定

プロジェクト (Projects)