フォントのインポート

Kanzi でのデフォルトのフォントファミリーは Fira Sans Regular です。フォントファイルは <KanziInstallation>/Studio/Asset Library/Fonts に保存されています。独自のフォントを使用したい場合は、それを Kanzi Studio プロジェクトにインポートしてください。

Kanzi アプリケーションでこれらのフォントタイプを使用できます。

Kanzi アプリケーションに含めたいテキストのすべてのグリフが含まれているフォントを使用していることを確認してください。

Kanzi Studio プロジェクトへのフォントのインポート

プロジェクトにフォントをインポートするには:

  1. File > Import > Import Fonts を選択します。

    Import Fonts ウィンドウが開きます。

    ../../_images/file-import-fonts.png
  2. Fonts 列でインポートしたいフォントを選択し、Typefaces 列でインポートするために選択したい書体をダブルクリックします。

    Import Fonts ウィンドウを開くと、Kanzi Studio がシステムフォントを表示します。別の場所からフォントをインポートするには、Browse をクリックし、インポートしたいフォントのディレクトリを選択します。

    ../../_images/import-fonts.png
  3. インポートしたい書体の選択が完了したら、Import をクリックします。

  4. Library > Font Families でインポートされたすべてのフォントを確認できます。

    ../../_images/font-families-in-library.png ../../_images/font-family-properties.png

iType リンクフォント

iTypeリンクフォントを使用して、複数のTrueTypeまたはOpenTypeフォントをリンクし、単一のフォントファイルを参照することで、リンクされたすべてのフォントからグリフを使用します。例えば、ラテン文字のフォントと中国語のグリフを持つフォントをリンクして、Kanzi アプリケーションで両方の言語で使用されるグリフをレンダリングすることができます。

要件

iTypeリンクフォントファイルを作成するには、Monotype iType FontLinking Kit 6.1.0.1が必要です。このバージョンのFontLinking Kitで作成したリンクフォントファイルは、iType 5.3.3と互換性があります。

iTypeリンクフォントファイルを使用するには、Kanzi にiTypeフォントエンジンを追加する Kanzi Engine プラグインが必要です。Kanzi iTypeフォントエンジンのリクエストは、support.rightware.com を通じて提出してください。

Kanzi Studio のための iType フォントエンジンのインストール

Kanzi Studio に iType フォントエンジンをインストールするには、

  1. iTypeフォントエンジン Kanzi Engine プラグインを含むzipファイルを抽出します。

  2. 各ビルド構成のdllファイルを <KanziInstallation>/Studio/Bin/EnginePlugins ディレクトリにコピーします。

    例えば、GL_vs<Version>_Release/kzitypeplugin.dll を <KanziInstallation>/Studio/Bin/EnginePlugins/GL_vs<Version>_Release ディレクトリにコピーします。

Android用iTypeフォントエンジンのインストール

Android 用の iType フォントエンジンをインストールするには:

  1. Rightware サポートによって提供された Kanzi-<Version>-android-freetype-itype.zip ファイルをダウンロードしてください。このファイルには、iTypeフォントエンジン Kanzi Engine プラグインが含まれています。

  2. <KanziWorkspace>/Engine ディレクトリに zip ファイルを抽出します。アーカイブを抽出する際、既に存在するファイルはスキップすることができます。

iTypeリンクフォントを使用する

iTypeリンクフォントを使用するには、

  1. ファイルエクスプローラーで、リンクしたいttfまたはotfフォントファイルを <ProjectName>/Application/bin ディレクトリにコピーします。

  2. lttリンクフォントファイルを作成するには:

    1. iType FontLinking KitでFontLinkerツールを開きます。

    2. Edit メニューで Modify を選択します。

      ../../_images/modify-linked-font.png
    3. Font Link ウィンドウで Add Font をクリックし、Application/bin ディレクトリにコピーしたフォントファイルを選択します。

      ../../_images/add-font.png ../../_images/added-fonts.png
    4. 前のステップでインポートした各フォントファイルの Font Link ウィンドウで、チェックボックスを選択し、Apply をクリックします。リンクしたいすべてのフォントを追加したら、OK をクリックします。

      ../../_images/font-checkbox.png ../../_images/click-apply.png
    5. File メニューで Save を選択し、リンクされたフォントを ltt ファイルとして保存します。

      ../../_images/save-font.png
  3. Kanzi Studio でリンクされたフォントを使用するには、

    1. Kanzi Studio で、前のステップで保存したlttフォントをインポートします。Kanzi Studio プロジェクトへのフォントのインポート を参照してください。

      Kanzi Studio では、Library > Font Families にリンクされたフォントファイルを確認できます。

      Fonts ディレクトリにリンクされたフォントファイルは、<ProjectName>/Application/bin ディレクトリにあるフォントファイルを参照します。

      ../../_images/linked-font-file-in-library.png
    2. Node Tree で、リンクされたフォントを使用したい Text Block または Text Box ノードを選択し、Properties で Font Family プロパティをそのフォントに設定します。

      その Text Block または Text Box ノードでは、リンクされたフォントファイルにリンクしたすべてのフォントファイルからグリフを使用できます。

      ../../_images/select-text-block.png ../../_images/set-font-property.png ../../_images/linked-font-in-preview.png

AndroidでiTypeリンクフォントを使用する

AndroidでiTypeリンクフォントを使用するには、

  1. Android用のiTypeフォントエンジンをインストールします。Android用iTypeフォントエンジンのインストール を参照してください。

  2. 使用したいフォントデータが ltt リンクフォントファイルに埋め込まれていることを確認してください。iTypeリンクフォントを使用する を参照してください。

  3. アプリケーションを起動時にiTypeフォントエンジンをロードするように設定するには、application.cfg に次を追加します。

    FontEngine = IType
    

    フォントエンジン を参照してください。

  4. Gradleビルドを構成してiTypeフォントエンジン Kanzi Engine プラグインdllにリンクするには、<ProjectName>/Application/configs/platforms/android_gradle/app/build.gradle ファイルで置き換えてください。

    externalNativeBuild {
        cmake {
            arguments "-DKANZI_LINK_FREETYPE=ON"
            arguments "-DKANZI_LINK_ITYPE=OFF"
        }
    }
    

    以下に置き換えます。

    externalNativeBuild {
        cmake {
            arguments "-DKANZI_LINK_FREETYPE=OFF"
            arguments "-DKANZI_LINK_ITYPE=ON"
        }
    }
    

ビットマップフォントの使用

固定ピクセルサイズのテキストを使用したい場合や、テキストのレンダリングに使用するリソースを少なくしたい場合は、ビットマップフォントを使用してください。ビットマップフォントの利点は、TrueTypeフォントやリンクされたiTypeフォントに比べて、ビットマップフォントのレンダリングに必要なリソースが少ないことです。ビットマップフォントの欠点は、ビットマップフォントをスケールすると、レンダリングされた結果の品質が低下する可能性があることです。

Kanzi は、AngelCode’s Bitmap Font Generator を使用してTrueTypeフォントから作成できるfntビットマップフォント形式をサポートしています。1つのビットマップフォントは、fntファイルと1つ以上の画像ファイルで構成されます。

ビットマップフォントを使用するには:

  1. AngelCode の Bitmap Font Generator で TrueType フォントからビットマップフォントファイルを作成します。

    1. Options メニューで Font settings を選択し、Font Settings ウィンドウで、ビットマップフォントの作成に使用する TrueType フォントとグリフのラスタライズ設定を選択します。

      ../../_images/bmp-fnt-gen-font-settings.png
    2. メインアプリケーションウィンドウで、ビットマップフォントを作成したい個々の文字または文字グループを選択します。

      ビットマップフォントのサイズを可能な限り小さく保つために、Kanzi アプリケーションで使用したい文字だけを選択してください。

      ../../_images/bmp-fnt-gen-char-select.png
    3. Options メニューで Export options を設定します。

      たとえば、以下を設定します。

      • フォントテクスチャの Width と Height を、選択したすべてのグリフが収まるように十分な大きさに設定しますが、それ以上大きくしないでください。1つのテクスチャに収まらない大量のグリフをエクスポートする場合、ツールは追加のテクスチャを作成します。テクスチャを作りすぎないように注意してください。そうしないと、Kanzi アプリケーションのパフォーマンスが低下する可能性があります。

      • Bit depth を 8 に

      • Preset を White text with alpha に

      • File format > Font descriptor を Text に

      ../../_images/bmp-fnt-gen-export-options.png
    4. Options メニューで Save bitmap font as... を選択し、ビットマップフォントのディレクトリとファイル名を選択します。

      ビットマップフォントを保存すると、アプリケーションはfntファイルを作成し、選択したグリフを1つ以上の画像にエクスポートします。これは、エクスポート設定と、そのビットマップフォント用に選択したグリフの数に依存します。

  2. Kanzi Studio プロジェクトでビットマップフォントを使用する:

    1. Kanzi Studio メインメニューで File > Import > Import Fonts を選択し、Import Fonts ダイアログで Browse をクリックし、ビットマップフォントを含むディレクトリを選択してフォントをインポートします。Kanzi Studio プロジェクトへのフォントのインポート を参照してください。

      Library > Font Families ではビットマップフォントを確認でき、Library > Resource Files > Fonts では、このビットマップフォントのラスタライズされたグリフを含む1つ以上の画像を持つフォントファイルを確認できます。

      フォント画像の場合、Kanzi Studio は sRGB Content プロパティを自動的に無効に設定します。Kanzi はこの設定を使用して、Kanzi Studio プロジェクトの Color Workflow が Linear に設定されているときにビットマップフォントを正しく表示します。カラーワークフロー を参照してください。

      ../../_images/file-import-fonts.png ../../_images/bitmap-font-file-in-library.png ../../_images/bitmap-font-file-image-properties.png
    2. Node Tree で、ビットマップフォントを使用したい Text Block または Text Box ノードを選択し、Properties で追加して設定します。

      • インポートしたビットマップフォントに Font Family

      • Font Size を フォント設定 のビットマップフォントジェネレーターで設定したサイズにします。

      ../../_images/select-text-block.png ../../_images/properties-text-block.png

関連項目

Text Block ノードを使用する

Text Box ノードを使用する

ローカライズ (Localization)