Kanzi Studio インターフェースのカスタマイズ¶
Kanzi Studio インターフェースをカスタマイズできます。新しいウィンドウを開いたり、再配置したり、ドッキングしたり、ウィンドウを閉じたりして、自分のニーズに最も適した環境を作成できます。
ワークスペースをデフォルトの状態に戻すには、メインメニューで Window > Reset Workspace を選択します。
これは、新しいプロジェクトを作成したときの Kanzi Studio の外観です。
ウィンドウを開く¶
新しいウィンドウを開くには、Window を選択し、開きたいウィンドウを選択します。
Activity Browser を使用して、アクティビティとアクティビティホストを作成および検査し、アクティビティのアクティベーションをシミュレートします。Activity Browser は、アプリケーション内のアクティビティのすべての可能なUI状態を表示します。
アクティビティブラウザの使用 を参照してください。
Animations は、プロジェクト内のアニメーションデータ、アニメーションクリップ、タイムラインシーケンス、およびタイムラインエントリを表示します。アニメーション (Animations) を参照してください。
Asset Packages は、Kanzi Studio プロジェクトにインポートできる、既製コンテンツのコレクションを表示します。アセットパッケージ を参照してください。
Assets は、プロジェクト内の2Dおよび3Dコンテンツ、マテリアル、プレハブを表示します。
Bookmarks はプロジェクト内のショートカットを表示します。ブックマークを使用する を参照してください。
Data Sources はプロジェクト内のデータソースを表示します。データソース (Data Sources) を参照してください。
Dictionaries は、Node Tree で選択したノードにローカルなリソースのリソースIDを表示します。
リソース (Resources) を参照してください。
Library は、プロジェクト内のすべてのリソースを表示します。ここでは、プロジェクト内のすべてのマテリアル、テクスチャ、アニメーション、トラジェクトリ、コンポーザー、その他のリソースを見つけ、作成し、編集することができます。各リソースタイプごとに個別のドッキング可能なウィンドウを開くことができます。リソース (Resources) を参照してください。
Log は、プロジェクト内でトリガーされたメッセージだけでなく、警告やエラーメッセージなど、プロジェクトのステータスを表示します。
Materials and Textures は、プロジェクト内のブラシ、マテリアル、マテリアルタイプ、シェーダーフォーマット、およびテクスチャを表示します。ブラシの使用、マテリアルタイプとマテリアル、バイナリシェーダーを使用すること、および テクスチャ (Textures) を参照してください。
Meshes はプロジェクト内のメッシュデータを表示します。メッシュの使用 を参照してください。
Node Components は、Node Tree で選択されたノードのトリガー、アニメーションプレーヤー、入力マニピュレーターなどのコンポーネントを表示します。ノードコンポーネント (Node Components) を参照してください。
Node Tree は、アプリケーションの起動時に Kanzi がロードするプロジェクト内のすべてのノードを表示します。ここでプロジェクトのコンテンツを作成し、整理します。
Pages は、アプリケーションの構造を作成および管理できるページツールを表示します。Page ノードと Page Host ノードを使用する を参照してください。
Prefabs はプロジェクト内のプレハブを表示します。ノードプレハブの使用 を参照してください。
Preview は、ユーザーに表示されるプロジェクトの様子を示します。Preview ウィンドウには、次のモードがあります。
Analyze モードでは、アプリケーションのパフォーマンスと内部構造を分析できます。プレビューでアプリケーションを分析する を参照してください。
Edit モードでは、Preview ウィンドウを使用してプロジェクト内のコンテンツを編集できます。Preview ウィンドウツール
のいずれかを選択して、Edit モードに入ります。Preview でアプリケーションを編集する を参照してください。
Interact モードでは、デバイス上と同じように Preview ウィンドウでアプリケーションを操作できます。Preview のツールを使用しているときに Interact モードに切り替えるには、Preview ウィンドウで
をクリックします。
Prism Editor は、Prism エフェクトを作成および編集できる Prism Editor を表示します。Prism グラフ を参照してください。
Properties は、Node Tree または Library で選択されたアイテムのプロパティを表示します。プロパティを追加、削除、または編集すると、選択されたアイテムの外観と動作を編集します。
Property Types は、プロジェクト内のカスタムプロパティタイプを表示します。プロパティタイプ (Property Types) を参照してください。
Rendering は、プロジェクト内のオブジェクトソース、レンダーパス、およびフィルタを表示します。オブジェクトソース (Object Sources) を使用する、レンダリング、および フィルタ を参照してください。
Resource Files は、ファイルタイプごとにグループ化されたプロジェクト内のリソースファイルを表示します。リソースファイル (Resource Files) を使用する場合 を参照してください。
State Managers は、プロジェクト内のステートマネージャーを表示します。ステートマネージャー (State Manager) を参照してください。
State Tools は、アプリケーション内で状態を作成、設定、および管理するために使用できるツールを示します。ステートマネージャー (State Manager) を参照してください。
Textures はプロジェクト内のテクスチャを表示します。テクスチャ (Textures) を参照してください。
Trajectories はプロジェクト内のトラジェクトリを表示します。トラジェクトリ (Trajectories) を参照してください。
ヒント
任意のツリービューで、アイテムの下にあるすべての要素を展開または折りたたむには、Ctrl を押したままエキスパンダー
をクリックします。
ワークスペース内のウィンドウの再配置¶
ワークスペースは、ウィンドウをドッキング、ドッキング解除、開閉することで再配置できます。
ウィンドウをドッキング解除するには、ウィンドウのヘッダーをクリックして、ガイドダイヤモンドの新しい場所にドラッグするか、ウィンドウを浮かせたままにするためにドロップします。
ウィンドウを閉じるには、閉じたいウィンドウのヘッダーにあるXをクリックします。
ウィンドウをドックするには:
ドッキングしたいウィンドウのヘッダーをクリックします。
ウィンドウがあるエリアの中央にガイドダイヤモンドが表示されます。
ウィンドウをドッキングしたいエリアにドラッグし、ガイドダイヤモンドの対応する部分に移動します。
ウィンドウがドックされるエリアがシェードされます。
マウスボタンを離して、ウィンドウを指定された位置にドックします。
任意のウィンドウを別のウィンドウにタブとして追加する¶
任意のウィンドウを他のウィンドウのタブとして追加することで、同じウィンドウ内で複数の種類のコンテンツを表示できます。
任意のウィンドウを別のウィンドウにタブとして追加するには:
ウィンドウのヘッダーをクリックしてドラッグし、タブとして追加したいウィンドウの上に移動し、ガイドダイヤモンドの中央部分に移動します。
マウスボタンを離して、ウィンドウをタブとして追加します。
Properties ウィンドウでプロパティカテゴリを並べ替える¶
Properties ウィンドウでプロパティカテゴリの順序を設定するには、Edit > User Preferences を選択し、Properties タブの Property Category ドロップダウンでプロパティカテゴリを選択し、プロパティカテゴリの位置を設定します。
例えば、Transform 2D と独自の My Property Category カテゴリを、Description カテゴリの後に表示するように設定できます。
注釈
General と Description プロパティカテゴリは常に上部に表示されます。