记录项目¶
在您的 Kanzi Studio 项目中添加节点和资源的文档,以描述项目中各项的用途。
为工程制作文档¶
要为工程制作文档:
在主菜单中选择 Project > Properties,并在 Description 中的 Properties 属性中为您的项目编写描述。
当您将鼠标悬停在项目名称上时,可以在 Kanzi Studio Quick Start 窗口中看到此描述。
在 Node Tree 或 Library 中选择您要添加描述的项目,在 Properties 中添加 Description 属性,并为该项目编写描述。
使用 Description 属性编辑器来格式化内容。您可以在描述中包含超链接。
选择 File > Export > Export Descriptions。
Kanzi Studio 会导出一个纯文本文件,其中包含具有 Description 属性的项的名称、路径和描述。Kanzi Studio 将该文件导出到存储该工程的工程文件的同一目录中。导出 kzb 文件时,Kanzi Studio 会排除 Description 属性。
小技巧
Kanzi Studio 默认情况下将描述文件命名为
<project_name>_descriptions.txt。您可以在 Project > Properties 中使用 Descriptions File Name 属性设置文件的名称。
当 Kanzi Studio 导出描述时,它会在 Status Bar 中添加链接到文本文件,您可以在 Library 窗口下方和 Log 窗口中找到该链接。单击链接以打开包含导出文件的目录。