フォントのインポート¶
Kanzi でのデフォルトのフォントファミリーは Fira Sans Regular です。フォントファイルは <KanziInstallation>/Studio/Asset Library/Fonts に保存されています。独自のフォントを使用したい場合は、それを Kanzi Studio プロジェクトにインポートしてください。
Kanzi アプリケーションでこれらのフォントタイプを使用できます。
TrueType と OpenType フォント (ttf および otf ファイル)
iType リンクフォント (ltt ファイル)。iType リンクフォント を参照してください。
ビットマップフォント(fntファイル)。ビットマップフォントの使用 を参照してください。
使用するフォントが、アプリケーション内のテキストに必要なグリフを備えていることを確認してください。FreeType フォントエンジンを使用する場合は、Unicode の書記体系ごとにフォールバック用のフォントファミリーを設定できます。フォントフォールバックの使用 を参照してください。
Kanzi Studio プロジェクトへのフォントのインポート¶
プロジェクトにフォントをインポートするには:
File > Import > Import Fonts を選択します。
Import Fonts ウィンドウが開きます。
Fonts 列でインポートしたいフォントを選択し、Typefaces 列でインポートするために選択したい書体をダブルクリックします。
Import Fonts ウィンドウを開くと、Kanzi Studio がシステムフォントを表示します。別の場所からフォントをインポートするには、Browse をクリックし、インポートしたいフォントのディレクトリを選択します。
インポートしたい書体の選択が完了したら、Import をクリックします。
Library > Font Families でインポートされたすべてのフォントを確認できます。
FreeType フォント¶
Kanzi には FreeType が含まれており、デフォルトのフォントエンジンとして使用されます。FreeType フォントを使用するために、別途フォントエンジンパッケージをインストールする必要はありません。
FreeType を使用して、Kanzi Studio プロジェクトにインポートした TrueType フォントおよび OpenType フォントをレンダリングします。FreeType は以下もサポートしています。
複数の書記体系、記号、または絵文字を含むテキストのためのフォントフォールバック。フォントフォールバックを使用する を参照してください。
サポートされているフォント形式でのカラー絵文字。FreeType でカラー絵文字を表示する を参照してください。
代わりに iType フォントエンジンを使用するには、iType リンクフォントのセクションにあるインストールと設定の手順に従ってください。
iType リンクフォント¶
iTypeリンクフォントを使用して、複数のTrueTypeまたはOpenTypeフォントをリンクし、単一のフォントファイルを参照することで、リンクされたすべてのフォントからグリフを使用します。例えば、ラテン文字のフォントと中国語のグリフを持つフォントをリンクして、Kanzi アプリケーションで両方の言語で使用されるグリフをレンダリングすることができます。
要件¶
iTypeリンクフォントファイルを作成するには、Monotype iType FontLinking Kit 6.1.0.1が必要です。このバージョンのFontLinking Kitで作成したリンクフォントファイルは、iType 5.3.3と互換性があります。
iTypeリンクフォントファイルを使用するには、Kanzi にiTypeフォントエンジンを追加する Kanzi Engine プラグインが必要です。Kanzi iTypeフォントエンジンのリクエストは、support.rightware.com を通じて提出してください。
Kanzi Studio のための iType フォントエンジンのインストール¶
Kanzi Studio に iType フォントエンジンをインストールするには、
iTypeフォントエンジン Kanzi Engine プラグインを含むzipファイルを抽出します。
各ビルド構成のdllファイルを
<KanziInstallation>/Studio/Bin/EnginePluginsディレクトリにコピーします。例えば、
GL_vs<Version>_Release/kzitypeplugin.dllを<KanziInstallation>/Studio/Bin/EnginePlugins/GL_vs<Version>_Releaseディレクトリにコピーします。
Android用iTypeフォントエンジンのインストール¶
Android 用の iType フォントエンジンをインストールするには:
Rightware サポートによって提供された
Kanzi-<Version>-android-freetype-itype.zipファイルをダウンロードしてください。このファイルには、iTypeフォントエンジン Kanzi Engine プラグインが含まれています。<KanziWorkspace>/Engineディレクトリに zip ファイルを抽出します。アーカイブを抽出する際、既に存在するファイルはスキップすることができます。
iTypeリンクフォントを使用する¶
iTypeリンクフォントを使用するには、
ファイルエクスプローラーで、リンクしたいttfまたはotfフォントファイルを
<ProjectName>/Application/binディレクトリにコピーします。lttリンクフォントファイルを作成するには:
iType FontLinking KitでFontLinkerツールを開きます。
Edit メニューで Modify を選択します。
Font Link ウィンドウで Add Font をクリックし、
Application/binディレクトリにコピーしたフォントファイルを選択します。
前のステップでインポートした各フォントファイルの Font Link ウィンドウで、チェックボックスを選択し、Apply をクリックします。リンクしたいすべてのフォントを追加したら、OK をクリックします。
File メニューで Save を選択し、リンクされたフォントを ltt ファイルとして保存します。
Kanzi Studio でリンクされたフォントを使用するには、
Kanzi Studio で、前のステップで保存したlttフォントをインポートします。Kanzi Studio プロジェクトへのフォントのインポート を参照してください。
Kanzi Studio では、Library > Font Families にリンクされたフォントファイルを確認できます。
Fontsディレクトリにリンクされたフォントファイルは、<ProjectName>/Application/binディレクトリにあるフォントファイルを参照します。
Node Tree で、リンクされたフォントを使用したい Text Block または Text Box ノードを選択し、Properties で Font Family プロパティをそのフォントに設定します。
その Text Block または Text Box ノードでは、リンクされたフォントファイルにリンクしたすべてのフォントファイルからグリフを使用できます。
AndroidでiTypeリンクフォントを使用する¶
AndroidでiTypeリンクフォントを使用するには、
Android用のiTypeフォントエンジンをインストールします。Android用iTypeフォントエンジンのインストール を参照してください。
使用したいフォントデータが ltt リンクフォントファイルに埋め込まれていることを確認してください。iTypeリンクフォントを使用する を参照してください。
アプリケーションを起動時にiTypeフォントエンジンをロードするように設定するには、
application.cfgに次を追加します。FontEngine = IType
フォントエンジン を参照してください。
Gradleビルドを構成してiTypeフォントエンジン Kanzi Engine プラグインdllにリンクするには、
<ProjectName>/Application/configs/platforms/android_gradle/app/build.gradleファイルで置き換えてください。externalNativeBuild { cmake { arguments "-DKANZI_LINK_FREETYPE=ON" arguments "-DKANZI_LINK_ITYPE=OFF" } }
以下に置き換えます。
externalNativeBuild { cmake { arguments "-DKANZI_LINK_FREETYPE=OFF" arguments "-DKANZI_LINK_ITYPE=ON" } }
ビットマップフォントの使用¶
固定ピクセルサイズのテキストを使用したい場合や、テキストのレンダリングに使用するリソースを少なくしたい場合は、ビットマップフォントを使用してください。ビットマップフォントの利点は、TrueTypeフォントやリンクされたiTypeフォントに比べて、ビットマップフォントのレンダリングに必要なリソースが少ないことです。ビットマップフォントの欠点は、ビットマップフォントをスケールすると、レンダリングされた結果の品質が低下する可能性があることです。
Kanzi は、AngelCode’s Bitmap Font Generator を使用してTrueTypeフォントから作成できるfntビットマップフォント形式をサポートしています。1つのビットマップフォントは、fntファイルと1つ以上の画像ファイルで構成されます。
ビットマップフォントを使用するには:
AngelCode の Bitmap Font Generator で TrueType フォントからビットマップフォントファイルを作成します。
Options メニューで Font settings を選択し、Font Settings ウィンドウで、ビットマップフォントの作成に使用する TrueType フォントとグリフのラスタライズ設定を選択します。
メインアプリケーションウィンドウで、ビットマップフォントを作成したい個々の文字または文字グループを選択します。
ビットマップフォントのサイズを可能な限り小さく保つために、Kanzi アプリケーションで使用したい文字だけを選択してください。
Options メニューで Export options を設定します。
たとえば、以下を設定します。
フォントテクスチャの Width と Height を、選択したすべてのグリフが収まるように十分な大きさに設定しますが、それ以上大きくしないでください。1つのテクスチャに収まらない大量のグリフをエクスポートする場合、ツールは追加のテクスチャを作成します。テクスチャを作りすぎないように注意してください。そうしないと、Kanzi アプリケーションのパフォーマンスが低下する可能性があります。
Bit depth を 8 に
Preset を White text with alpha に
File format > Font descriptor を Text に
Options メニューで Save bitmap font as... を選択し、ビットマップフォントのディレクトリとファイル名を選択します。
ビットマップフォントを保存すると、アプリケーションはfntファイルを作成し、選択したグリフを1つ以上の画像にエクスポートします。これは、エクスポート設定と、そのビットマップフォント用に選択したグリフの数に依存します。
Kanzi Studio プロジェクトでビットマップフォントを使用する:
Kanzi Studio メインメニューで File > Import > Import Fonts を選択し、Import Fonts ダイアログで Browse をクリックし、ビットマップフォントを含むディレクトリを選択してフォントをインポートします。Kanzi Studio プロジェクトへのフォントのインポート を参照してください。
Library > Font Families ではビットマップフォントを確認でき、Library > Resource Files > Fonts では、このビットマップフォントのラスタライズされたグリフを含む1つ以上の画像を持つフォントファイルを確認できます。
フォント画像の場合、Kanzi Studio は sRGB Content プロパティを自動的に無効に設定します。Kanzi はこの設定を使用して、Kanzi Studio プロジェクトの Color Workflow が Linear に設定されているときにビットマップフォントを正しく表示します。カラーワークフロー を参照してください。
Node Tree で、ビットマップフォントを使用したい Text Block または Text Box ノードを選択し、Properties で追加して設定します。
インポートしたビットマップフォントに Font Family
Font Size を フォント設定 のビットマップフォントジェネレーターで設定したサイズにします。