Write Log アクションを使用する

Write Log アクションを使用して、メッセージを Log ウィンドウに書き込みます。

../../_images/log-window.png

Log ウィンドウを開くには、メインメニューで Window > Log を選択します。

Kanzi は Log ウィンドウにメッセージ、警告、およびエラーを出力します。

Log ウィンドウへの書き込み

Log ウィンドウにメッセージを書き込みたい場合は、任意のトリガーで Write Log アクションを使用してください。

Log ウィンドウに書き込むには:

  1. Node Tree で、イベントに反応したいノードを作成または選択し、その結果として Log ウィンドウにメッセージを書き込みたいノードを選択します。

    例えば、Node Tree で、スクロール可能なコンテンツを持つ Scroll View 2D ノードを作成します。Scroll View ノードの作成 を参照してください。

    ../../_images/node-tree-scroll-view1.png
  2. Node Components で、Alt を押しながら右クリック Triggers を選択し、そのトリガーが発動されたときに Log ウィンドウに書き込むために使用したいトリガーを選択します。トリガーリファレンス を参照してください。

    例えば、Message Trigger > Scroll View > Scroll Ended トリガーを作成します。スクロールビューのスクロール位置が変更を完了したときに、Scroll Ended トリガーが発動します。

    ../../_images/node-components-create-scroll-ended.png
  3. Node Components > Triggers で、前のステップで追加した Alt を押しながら右クリック トリガーを選択し、Write Log アクションを選択します。

    ../../_images/node-components-write-log-action.png
  4. Write Log アクションでは、トリガーが作動したときに Log ウィンドウに書き込みたいメッセージを Log Text プロパティに設定します。

    ../../_images/node-components-write-log-action-log-text.png

Preview で、スクロールビューをスクロールしてスクロールが停止すると、Kanzi が Log ウィンドウに Log Text プロパティで設定したメッセージを出力します。

../../_images/log-window-scroll-ended.png

ヒント

Log ウィンドウを開くには、メインメニューで Window > Log を選択します。

Write Log アクションマクロの使用

Write Log アクションマクロを使用して、ログメッセージの内容に追加し、そのマクロの値で Kanzi を置き換えます。

Write Log アクションマクロを使用するには、

  1. Write Log アクションを作成します。Log ウィンドウへの書き込み を参照してください。

  2. Write Log アクションで、Enter Operation をクリックし、マクロを選択します。

    例えば、ノードの名前を手動で入力する代わりに、<Name> マクロを使用してください。

    <Name> マクロは、Write Log アクションを含むノードの名前を挿入します。

    マクロとテキストを組み合わせることができます。

    マクロ

    ディスクリプション (Description)

    <Name>

    Write Log アクションを含むノードの名前を挿入します。

    <EventName>

    Write Log アクションを実行するトリガーの名前を挿入します。

    {ValueSourceIndex}

    プロパティ値またはメッセージ引数を追加した後、そのアイテムの値を挿入します。プロパティまたはメッセージ引数からの値のログ記録 を参照してください。

    ../../_images/node-components-write-log-action-name-macro.png

Preview で、スクロールビューをスクロールしてスクロールが停止すると、Kanzi が Log ウィンドウに Log Text プロパティで設定したメッセージを出力します。

../../_images/log-window-scroll-ended-macro.png

プロパティまたはメッセージ引数からの値のログ記録

Write Log アクションを使用して、プロパティまたはメッセージ引数から Log ウィンドウに値を書き込むことができます。

プロパティやメッセージ引数から値をログに記録するには:

  1. Write Log アクションを作成します。Log ウィンドウへの書き込み を参照してください。

  2. Write Log アクションで、Add Value Source をクリックし、値を印刷したいソースを Log ウィンドウに設定します。

    たとえば、スクロールビューの X 軸上の位置を出力するには、設定します:

    • Value From から Message argument へ

    • Message Argument から Position X へ

    ../../_images/write-log-action-formatting-add-property.png
  3. Write Log アクションで、Enter Operation をクリックし、{ValueSourceIndex} を選択します。

    このマクロは、Kanzi が前のステップで追加した値に置き換える中括弧 ({}) を挿入します。

    ../../_images/write-log-action-formatting-add-format-string.png
  4. (オプション) 値を空の中括弧({})で参照する場合、Kanzi は値が Write Log アクションに現れる順序を使用します。メッセージ内の値の順序を設定するには:

    1. Write Log アクションに別の値を追加します。

      例えば、スクロールビューのy軸上の位置を印刷するには、Add Value Source をクリックして設定します。

      • Value From から Message argument へ

      • Message Argument から Position Y へ

      ../../_images/write-log-action-set-log-text-with-format-references.png
    2. Log Text で、もう一組の中括弧を追加し、その中括弧内にその位置で使用したい値のインデックスを入力します。

      例えば、Log Text プロパティを次のように設定します:

      New position. Y axis: {1}, X axis: {0}.
      
      ../../_images/node-components-write-log-action-custom-position.png ../../_images/log-window-scroll-ended-macro-custom-position.png

      ヒント

      Write Log アクション内の値の順序を変更するには、値の横にある矢印を使用します。

      ../../_images/write-log-action-move-item-up-down-buttons.png
  5. (オプション)。プロパティ値にフォーマットを適用できます。ログメッセージのフォーマット方法については、ログメッセージ引数フォーマット仕様 を参照してください。

    例えば、Log Text プロパティを次のように設定します:

    New position. Y axis {1:+.2}, X axis {0:+.2}.
    

    この方法でプロパティ値を次のようにフォーマットします:

    • 常に値の符号を表示する

    • 値の精度を小数点以下2桁に設定します。

    ../../_images/node-components-write-log-action-advanced-formatting.png ../../_images/log-window-advanced-formatting.png

関連項目

ロギング

トリガー (Triggers)