プロジェクトをドキュメント化する

Kanzi Studio プロジェクト内のノードとリソースのドキュメントを追加して、プロジェクト内のアイテムの目的を説明します。

プロジェクトのドキュメント化

プロジェクトをドキュメント化するには、

  1. メインメニューで Project > Properties を選択し、Description プロパティの Properties にプロジェクトの説明を書いてください。

    プロジェクト名にカーソルを合わせると、Kanzi Studio Quick Start ウィンドウでこの説明を見ることができます。

    ../../_images/project-properties-my-application.png ../../_images/project-description.png ../../_images/show-project-description.png
  2. Node Tree または Library で説明を追加したいアイテムを選択し、Properties で Description プロパティを追加し、そのアイテムの説明を書いてください。

    Description プロパティエディタを使用して、コンテンツをフォーマットします。説明にハイパーリンクを含めることができます。

    ../../_images/description-property.png
  3. File > Export > Export Descriptions を選択します。

    Kanzi Studio は、Description プロパティを持つアイテムの名前、パス、および説明を含むプレーンテキストファイルをエクスポートします。Kanzi Studio は、このファイルをプロジェクトの kzproj ファイルが保存されているディレクトリにエクスポートします。kzb ファイルをエクスポートする際、Kanzi Studio は Description プロパティを除外します。

    ../../_images/export-descriptions.png ../../_images/exported-descriptions.png

    ヒント

    Kanzi Studio はデフォルトで、説明ファイルを <project_name>_descriptions.txt と名付けます。Project > Properties で Descriptions File Name プロパティを使用して、ファイルの名前を設定できます。

    ../../_images/project-properties-my-application.png ../../_images/descriptions-file-name-property.png

    Kanzi Studio が説明をエクスポートすると、Status Bar にテキストファイルへのリンクが追加されます。このリンクは Library ウィンドウの下部と Log ウィンドウにあります。リンクをクリックすると、エクスポートされたファイルを含むディレクトリが開きます。

    ../../_images/descriptions-status-bar.png

関連項目

プロジェクトの作成

Kanzi Studio プロジェクトの設定

プロジェクトのバックアップを作成する

プロジェクトのインポート

プロジェクトのマージ

プロジェクトの中を整理すること

無効なプロジェクトアイテムを見つける

Kanzi でバージョン管理システムを使用する