Preview の制御¶
Kanzi Studio がプロジェクトをロードすると、Preview にプロジェクトがターゲットデバイス上でアプリケーションとして実行されたかのように表示されます。Preview は Project メニューから制御するか、ショートカットキーを使用して制御できます。
ショートカットキー |
ディスクリプション (Description) |
|---|---|
F5 |
Preview を一時停止モードで開始します。 |
F6 |
Preview の再生を開始します。 |
F7 |
Preview を一時停止します。 |
F8 |
Preview を終了します。 |
F9 |
Preview を停止します。 |
Ctrl F5 |
Preview をプレイモードで開始します。 デフォルトで、Kanzi Studio プロジェクトを開くときの Preview 設定です。この設定を変更するには、Edit > User Preferences > Advanced > Preview に移動します。 |
Ctrl F8 |
Preview を再起動します。 |
プレビューでのキーボード入力の制御¶
Preview がキーボード入力をどのように処理するかを制御するには、Preview がフォーカスを持ち、Interact モード
にあるとき、Preview で
をクリックします。
例えば、Preview を Text Box ノードに渡すために、Kanzi Studio ショートカットとして予約されているキーやキーの組み合わせからのキーボード入力も渡すには、Keyboard Input モードを有効にします。
プレビューのフォントエンジンを設定する¶
Kanzi は 2 つのフォントレンダリングバックエンドをサポートしています。
FreeType は、Kanzi に含まれているオープンソースベースのフォントエンジンです。ほとんどの一般的なユースケースに適しており、幅広いフォントフォーマットをサポートしています。FreeType ラスタライザー、HarfBuzz シェイパー、ICU バイディレクショナルライブラリ、および改行処理用の libunibreak を使用します。これがデフォルトのフォントエンジンです。
iType は、Monotype からの別途ライセンスが必要な商用ソフトウェアベースのフォントエンジンです。高度なフォントレンダリング機能と最適化を提供します。ラスタライズには Monotype iType ラスタライザーを、シェーピングには WorldType® Shaper™ を使用します。iType フォントエンジンのインストール を参照してください。
Preview のフォントエンジンを設定するには、
メインメニューで Project > Properties を選択します。
Properties の Profile で、Font Engine プロパティを以下に設定します。
FreeType: FreeType フォントエンジンを使用します。
iType: iType フォントエンジンを使用します。
None: フォントエンジンをロードしません。フォントエンジンをロードしない場合、Kanzi はアプリケーション内のテキストをレンダリングしません。
アプリケーションの起動時にどのフォントエンジンをロードするかを設定する方法については、フォントエンジン を参照してください。
注釈
iType フォントエンジンと FreeType フォントエンジンは、異なるレンダリングおよびシェーピングのアルゴリズムを使用します。そのため、テキストのレンダリングとレイアウトに多少の違いが生じることが想定されます。場合によっては、これらのフォントエンジンがフォントファイルの異なる部分を解釈することもあります。
一方の Font Engine からもう一方に切り替える場合、これらの違いを最小限に抑えるか解消するために、フォントファイル自体の更新または調整が必要になることがあります。
iTypeフォントエンジンのインストール¶
Kanzi iTypeフォントエンジンのリクエストを support.rightware.com を通じて提出してください。
Kanzi Studio に iType フォントエンジンをインストールするには、
iTypeフォントエンジン Kanzi Engine プラグインを含むzipファイルを抽出します。
各ビルド構成のdllファイルを
<KanziInstallation>/Studio/Bin/EnginePluginsディレクトリにコピーします。例えば、
GL_vs<Version>_Release/kzitypeplugin.dllを<KanziInstallation>/Studio/Bin/EnginePlugins/GL_vs<Version>_Releaseディレクトリにコピーします。
プレビュー用のOpenGL ESラッパーを設定する¶
Kanzi が Windows プラットフォームで OpenGL ES コンテンツをどのように処理するかを設定できます。Windows プラットフォームは OpenGL ES をサポートしていません。OpenGL ES は、深度ミップマップ、カラーフォーマット、テクスチャ圧縮、シェーダー言語などの機能において通常の OpenGL と異なります。
Preview のための OpenGL ES ラッパーを設定するには、
メインメニューで Project > Properties を選択します。
Properties で Preview OpenGL ES Wrapper プロパティを設定します。
GL (Emulation through desktop OpenGL) は直接OpenGLを呼び出します。これはデフォルトの設定です。
IMG (Imagination Technologies) は、Imagination Technologiesが提供するラッパーを使用して、デスクトップOpenGLを搭載したシステムでOpenGL ESの動作をエミュレートします。
Edit > User Preferences > Advanced で Default Preview OpenGL ES Wrapper を IMG (Imagination Technologies) に設定することにより、すべての Kanzi Studio プロジェクトのデフォルト値としてこれを設定できます。
注釈
IMG (Imagination Technologies) ラッパーは、開発に使用するには十分に安定していません。OpenGL ES を使用した場合にアプリケーションのグラフィックスがどのようにレンダリングされるかをテストするためだけに使用してください。コンテンツ開発には OpenGL を使用してください。
プレビューの背景色を設定する¶
Preview の背景はデフォルトで黒です。Preview が Interact モード
のときに、背景からコンテンツを際立たせるために、背景色を設定することができます。
すべての Kanzi Studio プロジェクトに対して。
メインメニューで、Edit > User Preferences を選択します。Preview タブで、Background Color プロパティを希望の色に設定します。
特定の Kanzi Studio プロジェクトの場合。
メインメニューで、Project > Properties を選択します。Properties > Preview プロパティカテゴリで、Preview Background Color プロパティを追加し、希望の色に設定します。
このプロパティを設定しない場合、プロジェクトは User Preferences で設定した色を使用します。
プレビューで Page ノードとプレハブのコンテンツのみを表示¶
デフォルトで、Preview は、ターゲットデバイス上でアプリケーションとして実行されたときのように、Kanzi プロジェクト全体を表示します。しかし、アプリケーションの一部を分離して、Preview 内でそれぞれを個別のアイテムとして表示することができます。これにより、プレハブをインスタンス化することなく、Page ノードやプレハブのコンテンツを作業することができます。
プレハブのコンテンツのみを Preview に表示するには、Prefabs でそのプレハブをダブルクリックします。
Kanzi Studio はプレハブを新しい Preview タブで開き、そのプレハブのコンテンツを Preview に表示します。
Page ノードのコンテンツのみを表示するには、Node Tree または Pages でそのページをダブルクリックします。Kanzi Studio は新しいタブで Page ノードを開き、その Page ノードのコンテンツを Preview に表示します。
Page ノードまたはプレハブを Preview で分離すると、Preview でアプリケーションのその部分を、Kanzi Studio の下部にあるタイムラインコントロールで制御できます。タイムラインを表示するには、Kanzi Studio のメインメニューで Window > Toolbar > Timeline を選択します。
Preview は、アプリケーション内で Page ノードまたはプレハブを再生モードまたは一時停止モードで表示します。
再生モードでは、Page ノードまたはプレハブは、スタンドアロンアプリケーションとして機能します。ユーザーインターフェースコンポーネントはインタラクティブで、アニメーションが再生されます。
一時停止モードではアニメーションは停止しますが、ユーザーインターフェイスコンポーネントはアクティブなままです。コンポーネントがアニメーションを実行する場合、再生モードに入るまでこれらは再生されません。
Preview が一時停止モードのとき、タイムラインバーでアプリケーション時間を設定できます。
Preview でこれらの再生モードを使用できます。
プレイバックモード (Playback Mode) |
ディスクリプション (Description) |
|---|---|
|
連続再生モードでは、Preview はタイムラインバーで設定した開始時間から再生を開始しますが、終了時間は設定されていません。 |
|
再生範囲モードでは、Preview はタイムラインバーで設定した開始時間と終了時間の範囲をループ再生します。 |
|
再生範囲と停止モードでは、Preview はタイムラインバーで設定した開始時間と終了時間の間の範囲を一度再生します。 |


