Kanzi Studio プロジェクトの設定¶
Kanzi Studio プロジェクトを構成するには、
プロジェクトを開き、メインメニューで Project > Properties を選択します。
Properties で、プロジェクトを構成するためにこれらのプロパティカテゴリのプロパティを設定します。
Description がプロジェクトを文書化します。プロジェクトをドキュメント化する を参照してください。
Application Settings は、Kanzi Studio が kzb ファイルとプロジェクトの kzb Player バージョンをエクスポートするディレクトリを設定します。kzbファイルの使用 を参照してください。
kzbファイルの内容を構成するための Binary Export。例えば、これらのプロパティを使用して:
メッシュと画像のエクスポートを最適化します。画像とテクスチャのベストプラクティス と メッシュの最適化 を参照してください。
Kanzi が kzb ファイルをロードする方法を設定します。Kanzi が kzb ファイルをロードする方法の設定 を参照してください。
カラーワークフローを設定します。カラーワークフロー を参照してください。
Kanzi Studio がプロジェクトをビルドするために使用するアプリケーション構成を設定するには、Building を使用します。Android ビルドの設定 を参照してください。
ノードやリソースを作成する際に使用したいアセットを設定するには、Default Assets を使用します。デフォルトアセットの設定 を参照してください。
Kanzi Engine プラグインと連携するように Preview を構成するための Preview。Kanzi Engine プラグインの作成 を参照してください。
設定する Profile:
kzbファイルとプロジェクト説明ファイルの名前。kzbファイルの使用 および プロジェクトをドキュメント化する を参照してください。
グラフィックスAPI。Kanzi でOpenGL ES 3.0+を使用する を参照してください。
Kanzi Studio Preview のフォントエンジン。プレビューのフォントエンジンを設定する および フォントエンジン を参照してください。
アセットパッケージとなるプロジェクト。アセットパッケージの作成 を参照してください。
Resources は、Kanzi と Kanzi Studio がリソースをどのように処理するかを設定します。Kanzi Engine が未使用のリソースをどのように処理するかを設定する を参照してください。
Timeline を使用して、プロジェクトのグローバルタイムラインの開始時間と終了時間を設定します。
タイムラインを表示するには、Window > Toolbar > Timeline を選択します。
デフォルトアセットの設定¶
新しいノードやリソースを作成する際に使用したいアセットを設定できます。
デフォルトのアセットを設定するには:
プロジェクトを開き、メインメニューで Project > Properties を選択します。
Default Assets カテゴリの Properties で、デフォルトで使用したいアセットを設定します。
Default Material は、Kanzi Studio が設定するマテリアルを、マテリアルがない状態で作成およびインポートするモデルに設定します。
Default Texture は、Kanzi Studio が設定する単一のテクスチャを、すべての新しい Image ノードおよびテクスチャを使用するマテリアルに設定します。
Default Cubemap Texture は、Kanzi Studio がキューブマップテクスチャを使用するすべての新しいマテリアルに設定するキューブマップテクスチャを設定します。
Import Material Type は、Kanzi Studio が3Dアセットファイルと共にインポートするマテリアルを割り当てるマテリアルタイプを設定します。
Kanzi が kzb ファイルをロードする方法の設定¶
kzbファイル内の Screen ノードの存在は、Kanzi がkzbファイルをどのようにロードするかを決定します。
Kanzi Studio がそのプロジェクトの kzb ファイルに Screen ノードをエクスポートするかどうかを設定するには、Node Tree で Screen ノードを選択し、Properties で Disable KZB Export プロパティを次のように設定します:
Screen ノードを含む kzb ファイルのエクスポートは無効になっています。これはデフォルトの設定です。Screen ノードを持つ kzb ファイルで Kanzi アプリケーションを開始できます。アプリケーションの実行中に Screen ノードを含む kzb ファイルをロードすると、アプリケーションが使用する Screen ノードを置き換えます。
Screen ノードなしでkzbファイルをエクスポートできるようになりました。Kanzi アプリケーションにすでに Screen ノードがある場合に限り、アプリケーションの実行時に Screen ノードなしでkzbファイルをロードできます。
プロジェクトプロパティタイプ¶
Kanzi Studio プロジェクトで利用可能なプロパティタイプのリストについては、プロジェクト (Project) を参照してください。
関連項目¶
Kanzi Studio プロジェクトを Kanzi アプリケーションに統合する