创建项目的备份

在 Kanzi Studio 中,您可以创建:

  • 自动备份。每次 Kanzi Studio 自动保存您的项目时,它会复制 .kzproj 项目文件并将其存储在一个带有 .autosave 扩展名的文件中。Kanzi Studio 仅存储一份 .autosave 文件的副本。请参阅 设置自动备份 和 从自动备份还原工程。

  • 手动备份。每次保存项目时,Kanzi Studio 会复制 .kzproj 项目文件,并将其存储在扩展名为 .kzproj_N 的文件中,其中 N 是备份的连续编号。Kanzi Studio 存储最近的十个项目文件备份。例如,如果您的项目名称是 Orchard,项目文件是 Orchard.kzproj,最新的备份是 Orchard.kzproj_1,倒数第二个备份是 Orchard.kzproj_2,依此类推。请参阅 从手动备份还原工程。

  • Restore Points。使用还原点返回到项目的早期版本。当您为项目创建还原点时,Kanzi Studio 会将项目的完整副本放入 <ProjectName>/Restore Points 目录中的一个带时间戳的目录中。请参阅 创建还原点 和 从还原点还原工程。

设置自动备份

每次 Kanzi Studio 自动保存您的项目时,它会复制 .kzproj 项目文件并将其存储在一个带有 .autosave 扩展名的文件中。Kanzi Studio 仅存储一个 .autosave 文件的副本。

默认情况下,Kanzi Studio 每 15 分钟自动保存您的项目。只有当您对项目进行更改时,Kanzi Studio 才会自动保存您的项目。

要设置自动备份,请选择 Edit > User Preferences,并在 Autosave 中:

  • 要应用自动备份,请启用 Enabled 设置。

  • 要设置自动备份之间的间隔时间,请在 Interval 文本框中输入分钟数。

    ../../_images/user-preferences-autosave-interval.png

从自动备份还原工程

要从自动备份中恢复您的项目,请选择 File > Open Backup Save,然后选择 Autosave 以打开自动备份。

../../_images/open-autosave-backup.png

从手动备份还原工程

每次保存项目时,Kanzi Studio 会复制 .kzproj 项目文件,并将其存储在扩展名为 .kzproj_N 的文件中,其中 N 是备份的连续编号。Kanzi Studio 存储最近的十个项目文件备份。例如,如果您的项目名称是 Orchard,项目文件是 Orchard.kzproj,最新的备份是 Orchard.kzproj_1,倒数第二个备份是 Orchard.kzproj_2,依此类推。

要从手动备份中恢复您的项目,请选择 File > Open Backup Save,然后选择 Backup 和您要打开的版本。

../../_images/open-manual-save-backup.png

创建还原点

使用还原点返回到项目的早期版本。当您为项目创建还原点时,Kanzi Studio 会将项目的完整副本放入 <ProjectName>/Restore Points 目录中的一个带有时间戳的目录中。

为您的工程设定还原点非常有用,这样,您就可以将工程恢复到某个时刻(例如对工程进行重大更改)之前的状态。

要创建还原点,请在 Kanzi Studio 中打开项目并在进行重大更改之前,选择 File > Save Restore Point。

Kanzi Studio 将您的项目完整复制到 <ProjectName>/Tool_project/Restore Points 目录中的一个带时间戳的目录中。

../../_images/save-restore-point.png

从还原点还原工程

要从还原点还原工程:

  1. 转到要还原的工程的工程目录,然后打开 Tool_project/Restore Points 目录。

  2. 打开要从中还原工程的带有时间戳的目录,然后打开 Kanzi Studio 工程文件。您选择的还原点的工程将在新的 Kanzi Studio 实例中打开。

另请参阅

清理您的项目

配置 Kanzi Studio 项目

工程 (Projects)