清理您的项目¶
在 Kanzi Studio 中,您可以删除项目中未使用的所有项目。从项目中删除未使用的项目并不总是能提高 Kanzi 应用程序的加载时间和性能。然而,这使得优化您的 Kanzi 应用程序变得更加容易,因为它帮助您专注于优化正确的内容。
通过删除项目未使用的内容,可以减小项目的 kzb 文件的大小:
当您完成项目时,删除项目未使用的所有资源和预设是一个好的做法。请参阅 删除默认纹理和图像 和 删除项目未使用的资源和预设。
如果您的项目不使用某个资源或节点,可以通过排除这些项目来优化 Kanzi 应用程序的大小。请参阅 排除应用程序中的项。
移除不动画任何内容的 Animation Data 通道。
删除 Kanzi Studio 在您打开项目时生成的临时文件。请参阅 移除生成的文件。
删除默认纹理和图像¶
当您创建项目时,Kanzi Studio 会向项目添加几个默认纹理和图像。这些基本资源使您能够在无需导入资源的情况下开始进行项目工作。然而,当您完成项目创建后,请删除这些纹理以减小 Kanzi 应用程序 kzb 文件的大小。
要删除默认纹理,请在 Library > Materials and Textures > Textures 中选择 Default Cubemap Texture、Default Texture 和 DefaultBackground,然后按下 Delete 键。
要删除默认纹理使用的图像文件,在 Library > Resource Files > Images 中选择 DefaultBackground.png、DefaultCubeMap.dds 和 DefaultTextureImage.png,然后按下 Delete 键。
删除项目未使用的资源和预设¶
完成工程后,最好删除工程未使用的所有资源和预设。删除未使用的资源可以减少应用程序使用的内存量,并简化工程的结构。
要删除工程中不使用的资源和预设:
在主菜单中选择 Project > Delete Unreferenced Items。
如果您的项目未使用某些资源或预设,Kanzi Studio 会在 Delete Unreferenced Items 窗口中列出它们。
小技巧
要仅删除特定类型的项目:
要仅从特定库中删除未使用的资源,请在 Library 中选择一个或多个您想要删除未使用资源的库,右键单击,然后选择 Delete Unreferenced Items。
要仅删除未使用的预设, 在 Prefabs 中右键单击并选择 Delete Unreferenced Items。
在 Delete Unreferenced Items 窗口中,选中您要删除的每个项目旁边的复选框,然后单击 OK。
(可选) 为了防止列出那些您使用 Kanzi Engine API 访问的项目:
要防止列出资源,在 Library 中选择资源,在 Properties 中添加 General > Is Used By Code 属性,并启用它。
要防止列出预设:
在 Prefabs 中,右键单击一个预设并选择 Show Prefab Template Properties。Properties 窗口显示该预设模板的属性。
在 Properties 中添加并启用 Is Used By Code 属性。
排除应用程序中的项¶
如果您的工程不使用某个资源或节点,可以通过排除这些项来优化您的 Kanzi 应用程序的大小。
要排除应用程序中的某个项:
在 Node Tree 或 Library 中选择该项目。
在 Properties 中添加并启用 Disable KZB Export 属性。
如果禁用另一个未禁用节点或资源所使用的节点或资源,应用程序将无法工作。例如,如果禁用一个由多个 Model 节点使用的 Mesh Data 资源,应用程序将无法工作。
删除冗余的 Animation Data 通道¶
无论是从第三方工具导入动画还是在 Kanzi 中创建动画,动画有时会包含不对任何内容进行动画处理的 Animation Data 资源。例如,当您通过将属性从 Properties 拖动到 Animation Clip Editor 来为 Render Transformation 添加关键帧时,Kanzi 会为所有属性属性添加一个 Animation Data 资源,即使它们没有发生变化。
请注意,Animation Data 资源中的静态值优先于节点的本地属性值。当您删除具有静态值的通道时,本地值将生效。因为有时即使是静态值(没有任何关键帧的 Animation Data 资源)也包含有效信息且是必需的,请根据具体情况考虑清理不必要的动画信息。
要移除冗余的 Animation Data 资源:
在 Library 中选择 Animations > Animation Clips,然后选择您的动画剪辑。
右键单击要为其删除冗余 Animation Data 资源的动画剪辑,然后选择 Delete Animations with One or Zero Effective Keyframes。
这些图像显示了在删除 Animation Data 资源之前和之后没有有效动画的相同 Animation Clip。
移除生成的文件¶
当您在 Kanzi Studio 中打开一个项目时,Kanzi Studio 会在项目目录中生成临时文件,例如压缩图像和缩略图。当您将 Kanzi Studio 项目移至版本控制时,或者当这些文件损坏时,您可以删除这些生成的文件。
要移除生成的文件,在主菜单中选择 Project > Clean Cached Files。