记录项目

在您的 Kanzi Studio 项目中添加节点和资源的文档,以描述项目中各项的用途。

为工程制作文档

要为工程制作文档:

  1. 在主菜单中选择 Project > Properties,并在 Description 中的 Properties 属性中为您的项目编写描述。

    当您将鼠标悬停在项目名称上时,可以在 Kanzi Studio Quick Start 窗口中看到此描述。

    ../../_images/project-properties-my-application.png ../../_images/project-description.png ../../_images/show-project-description.png
  2. 在 Node Tree 或 Library 中选择您要添加描述的项目,在 Properties 中添加 Description 属性,并为该项目编写描述。

    使用 Description 属性编辑器来格式化内容。您可以在描述中包含超链接。

    ../../_images/description-property.png
  3. 选择 File > Export > Export Descriptions。

    Kanzi Studio 导出一个纯文本文件,其中包括具有 Description 属性的项目的名称、路径和描述。Kanzi Studio 将此文件导出到存储项目的 kzproj 文件的同一目录中。当您导出 kzb 文件时,Kanzi Studio 排除 Description 属性。

    ../../_images/export-descriptions.png ../../_images/exported-descriptions.png

    小技巧

    Kanzi Studio 默认情况下将描述文件命名为 <project_name>_descriptions.txt。您可以在 Project > Properties 中使用 Descriptions File Name 属性设置文件的名称。

    ../../_images/project-properties-my-application.png ../../_images/descriptions-file-name-property.png

    当 Kanzi Studio 导出描述时,它会在 Status Bar 中添加链接到文本文件,您可以在 Library 窗口下方和 Log 窗口中找到该链接。单击链接以打开包含导出文件的目录。

    ../../_images/descriptions-status-bar.png

另请参阅

创建项目

配置 Kanzi Studio 项目

创建项目的备份

导入项目

合并工程

清理您的项目

查找无效的项目项

使用版本控制系统与 Kanzi。